Tuesday, November 12, 2013

Conflict when yum install perl-XML-SAX-0.96-7.el6.noarch on CentOS 6

When yum install perl-XML-SAX, you may encounter an error something like this

Transaction Check Error:
  file /usr/share/man/man3/XML::SAX::Base.3pm.gz conflicts between attempted 
installs of perl-XML-SAX-0.96-7.el6.noarch and perl-XML-SAX-Base-1.04-1.el6.rf.noarch
  file /usr/share/man/man3/XML::SAX::Exception.3pm.gz conflicts between attempted 
installs of perl-XML-SAX-0.96-7.el6.noarch and perl-XML-SAX-Base-1.04-1.el6.rf.noarch

The reason for this is due to the conflict of packages between the CentOS base repo (perl-XML-SAX-0.96-7)  and those found at rpmforge (perl-XML-SAX-Base-1.04-1).

The resolution is to disable the perl-XML-SAX-Base-1.04-1 found at rpmforge. You can do it by putting this line at /etc/yum.repos.d/rpmforge.repo

.....
.....
exclude=perl-XML-SAX-Base
.....
.....

1 comment:

Qarars said...

Great and thanks its work for me