Wednesday, September 22, 2010

Unable to update glibc for CentOS 4.x

I was trying to update glibc package on my old CentOS 4.x Server, but I seem to encounter errors such as these and unable to

Error: Unable to satisfy dependencies
Error: Package glibc-devel needs glibc = 2.3.4-2.43.el4_8.2, this is not available.
Error: Package glibc-devel needs glibc-headers = 2.3.4-2.43.el4_8.2, this is not available.

To allow the smooth update of glibc package first,
# yum remove glibc-devel glibc-headers glibc-kernheaders

Then finally update the glibc packages
# yum install glibc*

I've got the materials for this blog entry from Bug 6018 - Missing dependency in glibc packages yum not updating

No comments: